Back to overview
Downtime
Story Chain Planned Maintenance
Jan 15 at 02:40pm EST
Affected services
Story
Resolved
Jan 15 at 09:34pm EST
Story chain maintenance complete and the chain is now reenabled.
Affected services
Created
Jan 15 at 02:40pm EST
Story Chain has been disabled due to a planned maintenance. Visit https://www.storyscan.io/ for more information.
Affected services