Back to overview
Degraded
Bitcoin origin quotes unavailable
Jun 11, 2026 at 4:10am UTC
Affected services
Bitcoin
Updated
Jun 11, 2026 at 7:34am UTC
Partial liquidity has been restored
Affected services
Created
Jun 11, 2026 at 4:10am UTC
Bitcoin origin quotes are currently failing with 'No available routes'. We are currently working to resolve this issue.
Affected services