Back to overview
Downtime
Base Network Delays
Jun 25, 2026 at 4:50pm UTC
Affected services
Base
Resolved
Jun 25, 2026 at 6:40pm UTC
The Base network issue has been resolved. Transactions should now be processing normally.
Thank you for your patience while this was being sorted out. Let us know if you're still experiencing any delays.
Affected services
Created
Jun 25, 2026 at 4:50pm UTC
We're currently aware of an issue affecting the Base network that's causing transactions to be delayed. Our team is actively working on it and monitoring closely; your funds are safe in the meantime. You can follow live updates here: https://status.base.org/
Affected services