Back to overview
Resolved
Service degradation — Solana fill latency
Jul 10, 2026 at 4:05pm UTC
Affected services
Solana
Resolved
Jul 10, 2026 at 4:05pm UTC
We are currently seeing elevated fill times for transactions to and from Solana. Swaps and bridges involving Solana may take longer than usual to complete.
Funds are safe: transactions will complete once processed, and any transaction that ultimately fails will be refunded automatically.
We have identified a likely cause and are working on a fix. We'll post updates here as we have them.
Affected services