Back to overview
Resolved
Service Degradation - Robinhood Chain
Jul 11, 2026 at 10:03pm UTC
Affected services
Robinhood Chain
Resolved
Jul 11, 2026 at 10:11pm UTC
The issue has been resolved, and services on Robinhood Chain are now fully operational.
Affected services
Created
Jul 11, 2026 at 10:03pm UTC
We are currently seeing elevated fill times for transactions to and from Robinhood Chain. Swaps and bridges involving Robinnhood Chain may take longer than usual to complete.
Our team is working to resolve issue as soon as possible.
Affected services