Back to overview
Resolved

Fill Latency & Liquidity Degradation

Jul 17, 2026 at 12:31am UTC
Affected services
Ethereum
Base
Polygon
Solana
Robinhood Chain

Resolved
Jul 17, 2026 at 1:23am UTC

Incident has been resolved. Latency and liquidity balances are healthy and stable.

Created
Jul 17, 2026 at 12:31am UTC

We're currently seeing degraded fill latency and reduced liquidity across multiple chains. Our team is investigating root cause.