Back to overview
Resolved
Delayed transactions on Robinhood chain routes
Jul 23, 2026 at 2:31am UTC
Affected services
Robinhood Chain
Resolved
Jul 23, 2026 at 3:52am UTC
The issue affecting transactions to the Robinhood chain has been resolved. All services are operating normally.
Affected services
Updated
Jul 23, 2026 at 2:39am UTC
Transactions to the Robinhood chain are processing normally again. We're monitoring to confirm stability. Please report any continued issues.
Affected services
Created
Jul 23, 2026 at 2:31am UTC
We've identified an issue affecting transactions to the Robinhood chain and are working to restore normal processing. Funds are safe, and all other chains are operating normally.
Affected services